Close

Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Old Timer Panda's Avatar
    Join Date
    Sep 2013
    Location
    Antioch CA
    Posts
    3,058

    Today I learned...

    I thought it would be cool to start this thread to help each other learn from each other's mistakes or things we found out the hard way
    Example: this is when my friend Rick learned hydro assist is a force to be reckoned with ImageUploadedByWAYALIFE1413739206.611511.jpg
    Today I learned the evo rear track bar bracket for the enforcer lift is different from the coil over relocation bracket ImageUploadedByWAYALIFE1413739415.588170.jpg
    How bout you guys? Learned anything the hard way?

  2. #2
    Nothing but a Thing Serg5000's Avatar
    Join Date
    Mar 2012
    Location
    Palmdale, Ca
    Posts
    1,389


    I learned that having the proper sway bar angle will prevent tire side wall damage.
    Having it set as in the pic is the correct way.
    2008 X

  3. #3
    Old Timer Panda's Avatar
    Join Date
    Sep 2013
    Location
    Antioch CA
    Posts
    3,058
    Quote Originally Posted by Serg5000 View Post


    I learned that having the proper sway bar angle will prevent tire side wall damage.
    Having it set as in the pic is the correct way.
    That's good stuff to know

  4. #4
    Been Around the Block
    Join Date
    Jul 2014
    Location
    N/A
    Posts
    447
    Quote Originally Posted by Panda View Post
    That's good stuff to know
    X2

    Panda, can you spin the coil ?

  5. #5
    Old Timer Panda's Avatar
    Join Date
    Sep 2013
    Location
    Antioch CA
    Posts
    3,058
    Quote Originally Posted by 2007blackJk View Post
    X2

    Panda, can you spin the coil ?
    Oh no it's way too close I have the coil over bracket which is much different from the enforcer bracket, which none of this is evo's fault, long story, lol thanks though

  6. #6
    Not That Kind of Engineer olram30's Avatar
    Join Date
    Oct 2013
    Location
    wyoming
    Posts
    6,888
    Quote Originally Posted by Panda View Post
    Oh no it's way too close I have the coil over bracket which is much different from the enforcer bracket, which none of this is evo's fault, long story, lol thanks though
    I have a coil over bracket also. Didn't work either.

  7. #7
    -
    Join Date
    Aug 2013
    Location
    Fresno,CA
    Posts
    5,241
    Wasn't today,But...I learned how to uninstall, reinstall AND uninstall, reinstall my clutch twice in 24hrs or less because the one I got from Centerforce didn't fit right. Attachment 106022. Looked great all mounted up but just wouldn't engageImageUploadedByWAYALIFE1413757658.920730.jpg. Now we're having the great debate with Them to get a refund, after they inspect it of course

  8. #8
    Old Timer Panda's Avatar
    Join Date
    Sep 2013
    Location
    Antioch CA
    Posts
    3,058
    Quote Originally Posted by olram30 View Post
    I have a coil over bracket also. Didn't work either.
    Did you cut your factory bracket off like me before you realized it doesn't work only to disable your jeep till the new one comes?

  9. #9
    Old Timer Panda's Avatar
    Join Date
    Sep 2013
    Location
    Antioch CA
    Posts
    3,058
    Quote Originally Posted by ridg3runner View Post
    Wasn't today,But...I learned how to uninstall, reinstall AND uninstall, reinstall my clutch twice in 24hrs or less because the one I got from Centerforce didn't fit right. Attachment 106022. Looked great all mounted up but just wouldn't engageImageUploadedByWAYALIFE1413757658.920730.jpg. Now we're having the great debate with Them to get a refund, after they inspect it of course
    Great learning experience there

  10. #10
    Fresh Catch Topking's Avatar
    Join Date
    May 2016
    Location
    Ontario
    Posts
    9

    Today I learned...

    [QUOTE=ridg3runner;389470]Wasn't today,But...I learned how to uninstall, reinstall AND uninstall, reinstall my clutch twice in 24hrs or less because the one I got from Centerforce didn't fit right. Attachment 106022. Looked great all mounted up but just wouldn't engageImageUploadedByWAYALIFE1413757658.920730.jpg. Now we're having the great debate with Them to get a refund, after they inspect it of course :
    Last edited by Topking; 03-10-2017 at 02:35 AM.
    TK



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •